This project is read-only.

html generated code

Jan 31, 2011 at 1:38 PM

Hello,

I'm doing some tests with the dnn-menu provider but there is some strange things.

If I have a tab that is disable, the template generates me :

!-- LEVEL 2 -->
<!-- LEVEL 2 END -->
</li>
<li class=""><span class="disabled">My tab</span class="disabled">
<!-- LEVEL 2 -->

Why there is a class on the closing span tag?

 

In the default template, there is a css loaded:

<link id="Default/superfish.css" rel="stylesheet" type=

Is it possible to generate an id without the / char because it's not w3c valide?

 

Thanks for your work.

 

JB

Feb 2, 2011 at 10:57 PM

Hello jbval,

obviously this is a bug. I have already fixed it. It will be part of our next stabilisation release.

 

Thanks for using our DNN Menu and reporting this issue.


Greets,

Alex

Feb 3, 2011 at 10:30 AM

Hello,

thanks for your feedback. I started to look at the source code but I have not a lot of time at the moment and if the bug is fixed it's a good news!

I found your module interesting so I'm trying it ;)

 

Regards,

 

JB

Feb 8, 2011 at 5:45 PM

Hi,

I just want to give you a feedback about the last version. The span tag problem disapear and that's a good news !

There is still the problem of the <link id="Default/superfish.css"

The "/" char doesn't seems to be allow, I think it's possible to use an underscore or a dash instead.

 

The w3 validator raise also a problem about this part of html :

Line 41, Column 53: non SGML character number 0
<!-- LEVEL 1 END --></li></ul><!-- LEVEL 0 END --></div><div class="leftp">

 

I think it's a template problem, I will try to clean the comment to see if it's the problem remains.

Thanks for your works!

Regards,

 

Jean-Baptiste

Feb 13, 2011 at 2:25 PM

Thanks for your feedback.

I agree we should get rid of the slash and use a dash instead!

Feb 13, 2011 at 6:32 PM
Edited Feb 13, 2011 at 6:56 PM

Here is the modification to do:

\Templating\TemplateCSSFile.vb -> l.37 ->modify / by -

Edit :

Also the same modification for jsfile would be great:

\Templating\TemplateJSFile.vb  -> l.34 -> modify / by -

Feb 15, 2011 at 9:53 PM

Hello jbval,

I have fixed this. The change will be part of our next release. We will use an underscore instead of the slash in the IDs property for CSS and JS includes.

Thanks for the very detailed report :-).

Feb 16, 2011 at 8:48 AM

Good news for the modification!

Thanks for your answer.